single CompassをヴァージョンアップしたらCodekit2でコンパイルできなくなったときの対処法 | Heastea's Blog , loves Music & Movies

CompassをヴァージョンアップしたらCodekit2でコンパイルできなくなって焦りました。。

最新のCodekitだと若干反応が遅くて、

ササッとブラウザにいくと1回めのリロード時にコンパイルが間に合ってくれなかったので納得できず。

ターミナルのcompass w も反応がいまいち。。

なのでどうしても2に戻したいということで、、

ググってたらなんとか対処方法が見つかりました、、

結果、Compassのヴァージョンを下げることで解決しました、よかった(*_*;

gem uninstall compass

gem uninstall sass

gem install sass --version "3.2.10"

gem install compass --version "0.12.2"

ターミナルを使います、

使うのは1行ずつ順番にだよ(・・)

こちらを参考にさせていただきましたm(_ _)m

ぼうきゃくのかなた
http://560days.com/lab/2014/04/001528.php

ちなみに、このコマンドでエラー出る場合はおそらく権限がないよってことなんで、sudoをつければOKです。

そもそも、sudoってなんだ?ターミナルってなんだ?って方はこちらがおすすめ。

ターミナル以外にもいろんな基礎が学べます!

ドットインストール
http://dotinstall.com/lessons/basic_unix

自分もまだ初歩的なことしか理解してないですが(゜_゜)

sudo uninstall compass

sudo gem install compass --version "0.12.2"

ちなみに sudo は スーパーユーザードゥー の意味。 …のはず。

root権限で実行したいときに付けるんです。 …きっと。

自分はsassはそのままで、CompassだけヴァージョンダウンしたらCodekit2で無事コンパイルできるようになりました。

ありがたやm(_ _)m

今じゃネットさえあれば、

sudo?compass?sass?って思ったらすぐに調べられるんだもんな。

昔はちょっとしたことでも参考書とかで自力で解決してたんだもんな~~。

昔の人から見たらとてつもなく恵まれてるんだよな~こういうのって。

CompassをヴァージョンアップしたらCodekit2でコンパイルできなくなったときの対処法

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

Real time web analytics, Wordpress visitor counter, Wordpress visitor tracking
100{ae2f1535768421757994090bc6dbceb0562fb90aa9457e0de95b86efabd2693e}Japan Japan

Total: 89